Christopher W. Allen-Poole professional blog

February 24, 2010

Unfortunately WAMP really DOESN’T support SPL

Filed under: php, The Project, WAMP — frageanonym @ 8:11 pm

I’ve just determined that WampServer 2 does not support the PHP SPL Type library. It does support the PHP SPL library, but only in a very limited way. It does not support SplNotifier or SplObserver — and this is not insignificant.

Because my work machine (and my laptop) uses WAMP, this makes all progress with these classes severely limited. Perhaps with the next generation of WAMP I’ll be able to use them, but for now that really limits some of my ability to make progress with the new alternative to CI (after the project).

Advertisements

Create a free website or blog at WordPress.com.